Problem: When extracting a package a stream of errors are generated on installation of yarn.

gyp ERR! build error
gyp ERR! stack Error: not found: make
gyp ERR! stack at getNotFoundError (/theme/node_modules/which/which.js:13:12)

So the first solution you find says:

Please make sure you have node-sass higher than 4.12.0 as you have node 12.4.0 and node-sass was not supporting it until 4.12.0

So lets check the node version and update node-sass accordingly:

node -v


npm update node-sass@4.12

Which made absolutly no difference for me… I ended up going into the package.json file and manually updating the node-sass version to ^4.12 which worked a charm!

Leave a Reply

Privacy & more..

Cookie Consent Policy